git 1.8.x on CentOS

At the moment this is not on EPEL & CentOS repo, you'll have to compile from source. Get the desired version: http://code.google.com/p/git-core/downloads/list tar -xzvf ./git-1.8.x.tar.gz cd ./git-1.8.x ./configure make && make install

Make Command Not Found in CentOS

If you are getting this error, you will need to install the gcc automake. Type the following command: yum -y install gcc automake autoconf libtool make That's it!